Opamp trouble

Been working on the two stage opamp for my Sundar. The first stage takes the current from the photodiode and turns it into a voltage with a certain amount of gain. The second stage applies a second gain as well as an offset via two digital (SPI) potentiometers.

The first set of opamps I uses were 741s I had around. They did not work because the need +-9V and I am running on a 5V rail. The next set I picked up from Radio Shack were a bit better but still were not rail to rail. Next set I ordered from Digikey were rated rail to rail in the title, but only later did I find out that was only the case for larger voltages.

Last set I am working on (again from digikey) was designed for low voltage but although the input is rated rail to rail, the output still is not.

So after careful consideration and talking to every EE I know, I placed an order for some expensive opamps from Linear Technologies. These are rated for a single 5V supply with railt to rail inputs and outputs. Hope these work when they arrive early next week.

This entry was posted in AVC, Projects, SUNDAR. Bookmark the permalink.

2 Responses to Opamp trouble

  1. Michael says:

    Why do you need rail to rail? To increase range? Resolution? What’s the signal bandwidth? I’ve run into some struggles with op amps in the past.

    • Skye Sweeney says:

      The signal I am looking for could be huge or very small. If the sun is out bright and the sensor swings through it so the light is normal to the sensor, the sensor will peg. In that case R2R inputs and outputs are not really needed. But on a cloudy day, the signal from the sun may only be slightly above the average signal. In that case I want to maximize dynamic range by increasing the gain and adjusting the offset. Now I could do this with a few trim pots, but what happens if you get a change in sun brightness during an AVC run? For that I needed a ABC circuit to control the gain and offset. And to get the best performance both the input to the opamp and the output from it needed to be rail to rail. Now this is not that hard to get in a part powered with +-10V, but fairly rare for a single ended 5V rail. The part I am using now is an Analog Devices ADA4084.Seems to be working as advertized.
      As for bandwidth, it is very slow. I am sampling at 40kHz for a signal I expect to see peak once or twice a second. So even at 10Hz, I am not pushing this part at all.

      Have you done any GPS position accuracy characterization you might be able to share?

Leave a Reply to Skye Sweeney Cancel reply

Your email address will not be published. Required fields are marked *

Blue Captcha Image
Refresh

*